Bug de son...

Tout ce qui tourne autour d'Oblivion mais qui n'est pas lié aux traductions de la Confrérie.
Avatar du membre
Lysandre
Traducteur en herbe | Moddeur en herbe
Traducteur en herbe | Moddeur en herbe
Messages : 1010

Bug de son...

Message par Lysandre » 24 mai 2019, 23:34

Bon après avoir cherché sur le net et la Conf je n'ai pas trouvé d3 solutions à mon problème, donc je viens ici pour en parler,

Voila deux semaines que je tente de modder Oblivion pour pouvoir jouer sur pc alors qu'avant je n'y avait joué que sur Xbox 360, au début l'installation des mods était difficile, puis j'ai fini par y arriver à force de lire des guides, et surtout d'acheter une version d'Oblivion non Steam...

Puis voila, à force de faire des tests entre la version Steam et Cd, j'ai fini par remarquer un bug pénible qu'aucun patch ne semble corriger, quelque soit la version en fait le curseur de la musique dans les options se réinitialise tout le temps, ou même se baisse à fond quoique je fasse...

Et la plupart du temps il m'arrive de jouer sans me rendre compte que la musique s'est coupée, et c'est véritablement pénible, si quelqu'un à une solution du coup, je vous serait reconnaissant de m'en parler.

Merci.
Je n'ai de maitre que moi même.

Avatar du membre
noone
Moddeur aspirant
Moddeur aspirant
Messages : 745
Contact :

Re: Bug de son...

Message par noone » 25 mai 2019, 00:04

je ne connais pas oblivion mais une requête google m'a amené là
http://modsreloaded.com/sound-commands peut être utile ou un début de piste

:pensif: je dirai que c'est un script qui cause ça... alors pas sur que ton problème s'en aille avec un autre script mais qui sait il pourrait prendre le dessus ou écraser le précédent
Image

Avatar du membre
Lysandre
Traducteur en herbe | Moddeur en herbe
Traducteur en herbe | Moddeur en herbe
Messages : 1010

Re: Bug de son...

Message par Lysandre » 25 mai 2019, 11:56

Je vais essayer ça, merci noone :)
En espérant régler mon problème.
Je n'ai de maitre que moi même.

Avatar du membre
Redondepremière
Scribe | Traductrice d'élite
Scribe | Traductrice d'élite
Messages : 3596

Re: Bug de son...

Message par Redondepremière » 25 mai 2019, 15:41

Au cas où, Sounds Commands est également dispo sur Nexus.
Un autre plugin OBSE qui pourrait être utile est Enhanced Music and Control.

Plus spécifiquement, le bug pourrait être lié à un problème avec les fichiers inis du jeu. Sont-ils en lecture seule, as-tu apporté des modifications (et par quelle méthode) ?
Si gentille petite créature atlante, quelques secondes de recueillement pour toi.
Ah bas non. On a pas le temps. ~ MOrlOck, 2014

Les mods que j'ai d'installés (listes sujettes à évolution)

Modder Morrowind, Oblivion et Fallout 3 proprement de nos jours

Avatar du membre
Lysandre
Traducteur en herbe | Moddeur en herbe
Traducteur en herbe | Moddeur en herbe
Messages : 1010

Re: Bug de son...

Message par Lysandre » 25 mai 2019, 16:43

Oui j'ai apporté des modifications au fichier oblivion.ini ( d'après un guide de Wiwiland : https://wiwiki.wiwiland.net/index.php?t ... u_Oblivion) pour multiplier le temps pendant lequel le sang reste sur les armes, etc, au tout début de la page du guide de wiwiland...

J'ai modifié comme c'était demandé avec le bloc notes bForceFullLOD=1 et fDecalLifetime= 10000.0000, le reste y était déjà de base.

Et je comptais les mettre en lecture seule, mais est-ce que c'est vraiment une bonne idée ?
Je n'ai de maitre que moi même.

Avatar du membre
Redondepremière
Scribe | Traductrice d'élite
Scribe | Traductrice d'élite
Messages : 3596

Re: Bug de son...

Message par Redondepremière » 25 mai 2019, 19:03

Il y a plusieurs paramètres concernant la musique dans Oblivion.ini (dont un concernant le volume par défaut et un autre pour le volume dans le menu principal) ; il est possible qu'ils aient des valeurs erronées.

La lecture seule peut servir si toutes les modifications nécessaires sont faites et que le jeu tend à les supprimer ; ça peut être à tenter.
Si gentille petite créature atlante, quelques secondes de recueillement pour toi.
Ah bas non. On a pas le temps. ~ MOrlOck, 2014

Les mods que j'ai d'installés (listes sujettes à évolution)

Modder Morrowind, Oblivion et Fallout 3 proprement de nos jours

Avatar du membre
DamonYa
Traducteur en herbe
Traducteur en herbe
Messages : 329

Re: Bug de son...

Message par DamonYa » 25 mai 2019, 19:25

Supprime ton fichier ini (ou déplace le ailleurs si tu veux en garder une trace) et redémarre oblivion pour en générer un nouveau. Ca permettra déjà de voir si ça vient de modif que tu aurais fait.

Sinon à mon avis le tuto ini de wiwiland est dépassé

sinon si tu n'as pas de carte son périphérique mais une carte son intégré à la carte mère, change ces lignes ainsi :

bDSoundHWAcceleration=0
bMusicEnabled=0
iMaxImpactSoundCount=16

Jamais testé ceci dis, ayant une carte son périphérique.

Avatar du membre
Lysandre
Traducteur en herbe | Moddeur en herbe
Traducteur en herbe | Moddeur en herbe
Messages : 1010

Re: Bug de son...

Message par Lysandre » 27 mai 2019, 12:26

Je vais déjà essayer avec la lecture seule, je verrais pour le reste après, merci !
( ça change rien avec la lecture seule, le fichier.ini se re-modifie par lui même... )

DamonYa tu te doutes bien que si je mets 0 à bMusicEnabled ça va la désactiver non ? hors je veux conserver la musique.
Après pour bDSoundHWAcceleration j'ai mis à 0 et je sais pas ce que ça change, mais en jeu de toute façon le volume de la musique ne change pas, je dit bien pour l'instant, car ça le fait en principe dans les donjons ayléides/grottes et que je n'ai pas beaucoup exploré pour l'instant étant donné que j'ai trouvé un nouveau bug qui me casse les pieds...
( pnjs sans voix, notamment les drémoras dans la plaine d'Oblivion qui est accessible par Kvatch... )

Mais comme je crois avoir trouvé le fautif, ça va vite se régler.
Je n'ai de maitre que moi même.

Avatar du membre
DamonYa
Traducteur en herbe
Traducteur en herbe
Messages : 329

Re: Bug de son...

Message par DamonYa » 03 juin 2019, 15:07

En fait ça n'a rien à voir, ce sont des réglages pour voir si tu gagnes de la performances (surtout en combat) et si c'est le cas, on te suggères d'investir dans une carte son dédié. Sinon faudra choisir entre la musique ou des freezes en combat.

Désolé donc.

Ca pourrait venir d'un problème de codec sinon, oblivion utilise de vieux codecs DShow. Installe un pack, genre satsuki, k-lite etc... (m'enfin les windows récents normalement ont tous les codecs)

T'as pas installé un mod liés aux sons-musiques sinon ?

Avatar du membre
Lysandre
Traducteur en herbe | Moddeur en herbe
Traducteur en herbe | Moddeur en herbe
Messages : 1010

Re: Bug de son...

Message par Lysandre » 04 juin 2019, 16:47

Ne soit pas désolé, tu as essayé de m'apporter ton aide, et même si ça n'est pas parfait c'est déjà ça de pris, merci !

Par contre mon jeu est tout à fait fluide avec ou sans musiques, et sans freezes, le seul soucis c'est le curseur de la musique qui bouge tout seul, parfois le curseur se baisse à fond tout seul, parfois juste un petit peu, seulement je n'aime pas ces modifications qui se font toutes seules...

Et c'est quoi cette histoire de codecs ? je pourrais essayer d'installer un pack comme satsuki, ou k-lite mais j'aimerais d'abord savoir ce que ça fait avant...

Après je n'utilise pas de mods liés aux sons et aux musiques, j'utilisais avant Bruitages de Cyrodiil mais j'ai fini par le retirer il y a un bon bout de temps, et j'ai depuis au moins désinstallé et réinstallé le jeu 2 fois.
Je n'ai de maitre que moi même.

Répondre

Retourner vers « Aide »